Alert Error on No Records


#1

Just had an interesting one. Been using Alerts for a few weeks and they’re proving very useful.

However, now that I’ve resolved a lot of issues they are now hitting zero and hence have no rows in the data. As a result the Alert shows as (Error) instead of just 0.

It becomes unclickable and therefore I can’t do anything with it other than delete it and start again.

  1. Why does the absense of any records not just default to 0 - can this be an option added?
  2. Why does the alert become uneditable? Surely the hyperlink to go into edit should still be active, else how am I expected to fix a genuine error?

#2

Hi @StuartH,
I just tried an Alert with a zero row count and it seems to work fine for me without error.
Sorry! That’s possibly not what you wanted to hear.

You might have managed to save something like an incorrect period selection inside your favourite. I had one of those recently.

To get to edit your alert, I would hope you can use the burger menu (The three lines Icon in top left), select Favourites:
favourutes

Then select your favourite from the list, here is my Banana Count favourite:
alert_bananas

Hope you find your solution soon! :slight_smile:

Warm regards,

Richard


#3

Yeah I wondered that, from a developer point of view an error is usually something coded wrong.

However, even support agreed that a no record result will cause an error.

image

Thanks for the pointer on the burger menu though - still seems odd to disable the link on error.


#4


#5

Hi again @StuartH
Sorry I couldn’t be of more help. That error looks more likely to be a Phocas server error.
Is anything interesting appearing in the Error Logs?
Sometimes that can hold the secret.

Best wishes!

Richard


#6

Nope, it’s just an error off the back of no records - i’ve recreated it and i have a similar alert for another category that works fine.


#7

That’s interesting that you’re getting the error. I’ve tried to recreate the issue several different ways, but I get a “0” every single time. I would think that should be the default behavior.


#8

Hi @StuartH,

Are you getting that error on a Custom Mode query? If so then this was actually a bug which we have fixed for the 7.4.8 release, so you shouldn’t be getting an error anymore and the alert link should be enabled once you get on to that release.


#9

@pramod.dematagoda welcome to PUG!

@StuartH we had this issue a while back, support resolved it, I wish I could provide more technical assistance on it, but I am not sure what they did to fix it :stuck_out_tongue:


#10

Yes this is a custom report as i’ve put an advanced filter on it - we’re running our Phocas hosted, any idea when that update goes live?


#11

Ah… that was the key to duplicating the issue. Had to be in Custom mode. Soon as I changed one of my test to Custom I get the error.

@StuartH
New version should be live this coming Sunday, the 17th.


#12

It does look like this latest update did take care of this bug. At least it now works in my testing.


#13

Great, thanks. I now have another showing Error due to too much data!! Arrgghh!

Query time out!